x264 mit Adobe Premiere

    • Ich hab die entsprechende Datei mal hochgeladen. Ist ein Intro einer meiner Serien, im Prinzip aber nur der Beginn eines von Kevin Macleods Titeln. Ich habe als Test ein einfaches Schwarzbild mit dem Lied unterlegt und es in x264 AAC 320 Kb LC 44,1 KHz encodiert und der Sound klingt wie mit niedriger Bitrate und springt zwischen den Kanälen. 48 KHz bringt tatsächlich das gewünschte Ergebnis und der Fehler tritt nicht mehr auf. AC-3 hingegen bekommt es auch in 44,1 KHz vernünftig hin. Ich exportiere nur gerne grundsätzlich sauber lokal in 44,1, weil dies auch das Standard-Format für YouTube ist und ich auf meinen sauberen lokalen Encode mehr gebe als ihre online Verwurstung.

      Sound: drive.google.com/open?id=0Byg6t4dP4GziNmpGU0NGMWpxdEk

      Falls sich der Fehler bei euch nicht replizieren lässt - hier ein Video mit schwarzem Bild und dem fehlerhaften Sound, den ich mit AAC 44,1 KHz bei WAV Files immer bekomme: drive.google.com/open?id=0Byg6t4dP4GzidHBpRnpsVzFWdlE
    • Ja, diese Infoseite kenne ich und sie macht nicht wirklich Sinn, denn wenn man ein Video von YouTube herunterlädt, sein es nun die eigenen per Videomanager oder fremde über einen externen Service, dann haben diese Dateien eine 44,1 Spur. Das macht eine ganze Community etwas stutzig. Auch die Angabe, dass Surround unterstützt wird - das sieht man auch wieder an den heruntergaladenen Dateien, die immer auf Stereo runtergemischt werden. Man möchte meinen, so ein großes Unternehmen wüsste schon, welche Angaben richtig sind aber es sieht einfach so aus, als ob das ein Teil von dem wäre, was unterstützt wird und nicht das Format, das von ihnen nicht weiter verarbeitet werden muss.
    • Ja, sie transkodieren das Material immer. Ich habe auch einen YT Channel und wende auch einen Haufen Tricks (Bildgröße, Framerate, ...) an um mehr Bandbreite und den besseren Codec (VP9) zu bekommen. Allerdings ist es immer besser höherwertig hochzuladen. Du weisst nie wann sie ihren Encoder umstellen und eine bessere Qualität ermöglichen. Ist aber marginal 44,1 ~ 48 ...

      Zu deinem Beispiel Schwarzstreifen.mp4:
      • Ich kann die Datei sowohl mit VLC als auch mit dem Browser Player von Chrome fehlerfrei abspielen. Der Ton ist sauber. Ich höre keine Fehler.
      • Nach einem Upload auf YT kann ich sie auch dort fehlerfrei abspielen
      • MediaInfo sieht sehr sauber aus:

      Quellcode

      1. General
      2. Complete name : C:\Users\Daniel\Downloads\Schwarzstreifen.mp4
      3. Format : MPEG-4
      4. Format profile : Base Media
      5. Codec ID : isom (isom/iso2/avc1/mp41)
      6. File size : 1.31 MiB
      7. Duration : 28 s 724 ms
      8. Overall bit rate mode : Variable
      9. Overall bit rate : 383 kb/s
      10. Tagged date : UTC 2017-11-01 16:19:19
      11. Writing application : Lavf57.7.2
      12. ©TIM : 00:00:00:00
      13. ©TSC : 60
      14. ©TSZ : 1
      15. Video
      16. ID : 1
      17. Format : AVC
      18. Format/Info : Advanced Video Codec
      19. Format profile : High@L4.2
      20. Format settings, CABAC : Yes
      21. Format settings, ReFrames : 4 frames
      22. Codec ID : avc1
      23. Codec ID/Info : Advanced Video Coding
      24. Duration : 28 s 700 ms
      25. Bit rate : 34.8 kb/s
      26. Width : 1 920 pixels
      27. Height : 1 080 pixels
      28. Display aspect ratio : 16:9
      29. Frame rate mode : Constant
      30. Frame rate : 60.000 FPS
      31. Color space : YUV
      32. Chroma subsampling : 4:2:0
      33. Bit depth : 8 bits
      34. Scan type : Progressive
      35. Bits/(Pixel*Frame) : 0.000
      36. Stream size : 122 KiB (9%)
      37. Writing library : x264 core 148 r2795 aaa9aa8
      38. Encoding settings : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / lookahead_threads=2 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=crf / mbtree=1 / crf=21.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
      39. Color range : Limited
      40. Color primaries : BT.709
      41. Transfer characteristics : BT.709
      42. Matrix coefficients : BT.709
      43. Audio
      44. ID : 2
      45. Format : AAC
      46. Format/Info : Advanced Audio Codec
      47. Format profile : LC
      48. Codec ID : 40
      49. Duration : 28 s 724 ms
      50. Duration_LastFrame : -23 ms
      51. Bit rate mode : Variable
      52. Bit rate : 331 kb/s
      53. Channel(s) : 2 channels
      54. Channel positions : Front: L R
      55. Sampling rate : 44.1 kHz
      56. Frame rate : 43.066 FPS (1024 spf)
      57. Compression mode : Lossy
      58. Stream size : 1.13 MiB (86%)
      59. Default : Yes
      60. Alternate group : 1
      Alles anzeigen

      Ich habe es auch selber nochmal probiert mit CS6 zu exportieren -> kein Fehler!

      Welche Player verwendest du bei dem du den Fehler hörst?
    • Ich benutze den MPC-HC. Aber ich höre den Unterschied auch in Premiere. Hast du dir mal die pure Sounddatei angehört und das miteinander verglichen? Ich kenne diesen Ausschnitt auch ganz genau, vielleicht fällt mir das deshalb eher auf. Gerade das Hihat klingt bei weitem nicht mehr so sauber und es "springt" wie ich finde. Das WAV ist sauber, das Video nicht. Wenn du beides in ein Projekt importierst und vielleicht abwechselnd mutest oder Teile von beiden zu einer Spur zusammenschneidest, hörst du es vielleicht.
    • Mein Gott, du hast ein feines Gehör. Habs jetzt auch gehört.

      Gibt drei Möglichkeiten:
      1. Rundungsfehler (Bei 96KHz klingts auch gut) wobei ich da aber vollkommen auf libav und deren Filter-Graphen setze
      2. Schwächen des psychoaukustischem Modell des AAC Encoders
      3. Die Qualität das AAC Encoders.
      Ich werde mal den Fraunhofer FDK Encoder einbinden. Der hat derzeit die höchste Qualität.
    • Danke für deine Bemühungen. Wundert mich, weil der AAC Encode von Premiere (also nur Sound exportieren) auch in 44,1 KHz funktioniert, die Quelle und das Projekt sind auch in 44,1 (also dachte ich, es könne gar keine Konflikte geben) und es taucht nur bei WAV Files auf. Vom technischen Standpunkt verstehe ich nicht genug, um da einen Sinn zu erkennen. Ist für mich nicht nachvollziehbar. Wenigstens weiß ich jetzt, dass ich nicht verrückt bin. ^^
    • Neu

      Eine Frage von mir als Laie. Ist es auch möglich eine h265 Importmöglichkeit für Adobe Premiere CS6 zu programmieren?
      vg Ian
    • Neu

      Danke für die rasche und vor allem positive Antwort. Bis jetzt kenne ich für CS6 nur die Möglichkeit h265 vor dem Bearbeiten zu konvertieren. "Test 265er Material" habe ich mit XMedia Recode umgewandelt.
      vg Ian